Back to overview
Degraded

Airship dashboard running slowly

Feb 07 at 01:38pm GMT
Affected services
Airship Dashboard
Airship Forms

Resolved
Feb 07 at 05:18pm GMT

Normal platform speed and responsiveness has been restored.

Our engineering team is continuing to monitor.

Created
Feb 07 at 01:38pm GMT

The Airship dashboard and API is currently running slowly.

Our engineering team is investigating and working to a resolution as soon as possible.