Back to overview
Degraded

Degraded experience on Airship Rewards

Mar 15 at 08:15pm GMT
Affected services
Airship Forms

Resolved
Mar 15 at 10:38pm GMT

Service has now been restored to Airship Rewards and Forms.

We apologise for the inconvenience this evening.

Created
Mar 15 at 08:15pm GMT

Airship Rewards is currently experiencing slow response times and timeouts which is affecting guests ability to access some vouchers.

Our engineering team is investigating as a priority.