Back to overview
Resolved

Degraded performance: Rewards and Forms

Aug 12, 2026 at 12:04pm UTC
Affected services
Airship Rewards
Airship Forms

Resolved
Aug 12, 2026 at 5:01pm UTC

The database performance issue affecting Rewards, Forms and Vouchers has been addressed and we're seeing normal performance return across the platform. We're monitoring closely to confirm full stability before marking this resolved.

Updated
Aug 12, 2026 at 3:04pm UTC

We’re continuing to experience degraded performance following a database issue that began at around 12:00 BST today.

What this means for you:

  • Rewards: may be slow or temporarily unavailable
  • Forms: may load normally, but submissions can fail or be delayed
  • Campaign sending: some scheduled or triggered sends may be delayed

Our team is actively working with our database provider to restore full service as quickly as possible. We know this may affect time-sensitive activity, and we’re sorry for the disruption.

We’ll share another update as soon as we have more information.

Created
Aug 12, 2026 at 12:04pm UTC

We're currently experiencing degraded performance following a database issue that began around 12:00 BST today.

What you may notice:

Rewards: may be slow or temporarily unavailable
Forms: forms will load as normal, but submissions may fail or be delayed
We have identified the cause and we're working to restore full service.

We'll post our next update shortly.