Partial outage: Hosting provider outage
Resolved
Apr 10 at 01:08pm BST
At 11:45 today we restored connection and all services have resumed normal functionality.
Affected services
Airship Dashboard
Airship Forms
Airship Rewards
Updated
Apr 09 at 04:33pm BST
An update on today's activities. We are continuing to put all resources into restoring connection. We wanted to extend our gratitude to our customers for understanding and working with us during this incident.
We have received reports of some form 'embed' links not functioning. This is not universal, affected some account and not others. For this reason we are marking as Forms with a Degraded status.
The Airship Rewards status remains degraded as some accounts are on default styling.
Affected services
Airship Dashboard
Airship Forms
Airship Rewards
Updated
Apr 08 at 03:41pm BST
We have identified that some legacy email templates are not displaying saved images.
The work to restore these is wrapped up in the continued work to reestablish connection with the hosting provider.
Affected services
Airship Dashboard
Airship Rewards
Updated
Apr 08 at 10:32am BST
A further update after a focussed start to the week. We are continuing to work on any remaining issues, as well as restoring the original connection to the host providers.
We have done some further work on reward to fix a remaining issue where some forms of rewards links were hitting a dead end.
We have also rectified an issue with the customer preference centre that was related to the outage.
The Airship Rewards degraded flag remains because we strill have some accounts on default styling.
Collation and writing up of the incident is still in progress.
Affected services
Airship Dashboard
Airship Rewards
Updated
Apr 06 at 07:41am BST
Rewards The loading of Rewards has been restored, however many customer will see a default styling and no Reward images. Functionality has been restored. This was down roughly between 17:30 04/04/25 and 21:50 05/04/25
Affected services
Airship Dashboard
Airship Rewards
Updated
Apr 05 at 10:50am BST
Comtrex vouchers These can now being redeemed in-venue. Redemptions were down between roughly 17:30 04/04/25 and 10:45 05/04/25
Affected services
Airship Dashboard
Airship Rewards
Updated
Apr 04 at 07:56pm BST
Going into the evening and weekend, here is a summary of the current state of things in one place.
What's been restored?
Platform speed Over night the platform was running slowly. This issued existed roughly between 17:30 03/04/25 and 08.45am 04/04/2025.
Links in emails Links in emails, as well as link tracking, was not operational, but both have been reinstated. *Please note, * there will be some loss of click track reporting during the affected downtime. This is roughly between 17:30 03/04/2025 to 11:30 04/04/2025.
What service degradation remains?
Rewards We are seeing intermittent failure to load rewards
Comtrex vouchers Comtrex currently cannot redeem vouchers issued through Airship
125 Data & Insights (formally known as Feed It Back) Advanced return path of data not working.
Legacy forms Some legacy forms are no longer rendering
To recap, what happened in the first place?
One of our hosting providers which houses some of our system had a power outage. This knocked services out, and we have been working to reinstate functionality.
Affected services
Airship Dashboard
Airship Rewards
Updated
Apr 04 at 05:09pm BST
We have been experiencing intermittent issues with Rewards being presented to the guests. Resolving this is in progress.
Affected services
Airship Dashboard
Airship Rewards
Updated
Apr 04 at 05:00pm BST
Click-tracking reporting is now available for all links in Airship emails. It is important to note there will be missed data for any links clicked during the downtime.
Affected services
Airship Dashboard
Airship Rewards
Updated
Apr 04 at 03:58pm BST
Following continued work throughout the day:
- Links from Airship emails are functional, however tracking is not available.
- We are still seeing issues with the redemption of Airship-issued vouchers through Comtrex.
Affected services
Airship Dashboard
Airship Rewards
Created
Apr 03 at 06:35pm BST
We are currently experiencing an outage with some parts of the Airship platform.
This is affecting:
- Links and click-tracking in Airship emails, which are not resolving as a result.
- The Comtrex <> Airship voucher service. This is causing issues with in-venue redemption of Airship issued voucher codes.
The problem is due to an issue with one of our upstream providers, who are working on a fix as a matter of urgency.
Affected services
Airship Dashboard
Airship Rewards