Back to overview
Degraded

Email builder image upload issues

Sep 25 at 02:29pm BST
Affected services
Airship Dashboard

Resolved
Sep 25 at 03:48pm BST

The issue with image uploads in our email builder has now been resolved. All services are running normally again.

Thank you for your patience while we worked with our supplier to restore full functionality.

Updated
Sep 25 at 03:04pm BST

We have identified the cause of the service interruption as being related to one of our upstream suppliers.

We are working closely with the supplier as a matter of priority to restore full service. Further updates will be provided as soon as more information is available.

Thank you for your patience while we work to resolve this.

Created
Sep 25 at 02:29pm BST

We are aware of some issues with our email builder which is causing problems with image uploads.

Our engineers are currently investigating as a priority.