Back to overview
Downtime

Platform Disruption – Dashboard, Rewards, Forms & API

Jun 15, 2026 at 6:25pm UTC
Affected services
Airship Dashboard
Airship Rewards
Airship Forms
Airship REST API

Resolved
Jun 15, 2026 at 7:21pm UTC

All services have been restored and are operating normally. We can confirm that this disruption was caused by a planned software update that had an unexpected impact on the platform. We have taken steps to prevent a recurrence.

We apologise for any inconvenience this caused. Thank you for your patience.

Created
Jun 15, 2026 at 6:25pm UTC

We are currently experiencing an issue affecting the Airship platform. The following services are impacted:

  • Airship Dashboard
  • Rewards
  • Forms
  • API

The disruption began at around 19:25 today. Our team is actively investigating and working to restore full service as quickly as possible.