Unscheduled Maintenance — In Progress
Resolved
Jul 14, 2026 at 5:00pm UTC
Maintenance ended
Affected services
Updated
Jul 14, 2026 at 4:57pm UTC
Airship is now back online and fully operational. Any emails or broadcasts that were queued during the maintenance window will send automatically — no action is needed on your end. We'll continue to monitor closely and will post again if anything changes.
Affected services
Updated
Jul 14, 2026 at 4:35pm UTC
Work to restore Airship is continuing and we expect to have service back soon. We'll update this page as soon as everything is fully restored.
Affected services
Updated
Jul 14, 2026 at 3:47pm UTC
We're continuing work to restore Airship. Thank you for your patience — we'll update this page as soon as service is back to normal.
Affected services
Created
Jul 14, 2026 at 3:20pm UTC
We've identified a performance issue and are carrying out maintenance to resolve it. Airship will be unavailable for approximately 30 minutes while this work completes. No action is needed on your end — we'll post an update here once service is back to normal.
Affected services