Back to overview
Resolved
Rewards and Forms performance restored
Jul 15, 2026 at 7:30pm UTC
Affected services
Airship Dashboard
Airship Rewards
Airship Forms
Airship REST API
Resolved
Jul 15, 2026 at 7:30pm UTC
This incident is now resolved. Rewards, forms, and the wider platform are operating normally. Apologies again for the disruption, and thank you for bearing with us. If you continue to see any issues, please contact support.
Affected services