Back to overview
Resolved
Broadcast sends may be delayed — all other services operational
Jul 17, 2026 at 10:31am UTC
Affected services
Airship Dashboard
Airship Rewards
Airship Forms
Airship REST API
Resolved
Jul 17, 2026 at 10:31am UTC
Platform is operational. Some scheduled and automated broadcast sends may be delayed while we apply the final part of a performance fix. All other services are running normally and we're monitoring closely.
Affected services